Skip to end of metadata
Go to start of metadata

Below you can find the main requirements for a server SmartJobBoard software will be installed to.
The software will not function properly without these minimum requirements from your host.

  • Supported Web Servers:
  • Apache (with mod_rewrite)
  • Lighttpd
  • LiteSpeed

  • PHP 5.3.9 with the following extensions:
  • GD
  • DOM - extension that allows you to operate on XML documents through the DOM API with PHP 5;
  • MySQLi or PDO extension - these extensions allow you to access the functionality provided by MySQL 4.1 and above.
  • json
  • mb_string
  • openssl
  • Curl php - extension that allows you to connect and communicate to many different types of servers with many different types of protocols;
  • bcmath extension (for Jobg8 plugin) - Mathematical PHP extension allowing precise calculations needed for Jobg8 integration;

  • Zlib & Zip extensions - for compression of content and automatic updates.

  • PHP Soap extension - for Jobg8 plugin

PHP code is processed by an interpreter application in command-line mode performing desired operating system operations and producing program output on its standard output channel.
SmartJobBoard software is built on PHP.

 

  • mod_rewrite

This module provides a rule-based rewriting engine to rewrite requested URLs on the fly.

  • MySQL 4.1.x or higher

MySQL is a relational database management system (RDBMS) that runs as a server providing multi-user access to a number of databases.
The users, listings and most of the system data is stored in the database.

 

  • GD library

GD library is used for the dynamic creation of images. It is installed as the extension for PHP.
GD creates PNG, JPEG and GIF images, among other formats.

 

  • FFmpeg library (for video uploads)

FFmpeg is a complete, cross-platform plugin to record, convert and stream audio and video.
It includes libavcodec - the leading audio/video codec library.

 

  • open_basedir should be turned off.   

 

  • No labels